summaryrefslogtreecommitdiff
path: root/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild
index a762ca1480b9..5eda59e817ee 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-4.0.1.ebuild
@@ -35,8 +35,7 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-lang/perl
dev-ml/findlib
- test? ( dev-ml/ounit
- $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )
+ test? ( dev-ml/ounit )
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
@@ -48,11 +47,6 @@ S=${WORKDIR}/${MY_P/_/}.src
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
-python_check_deps() {
- ! use test \
- || has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
pkg_setup() {
LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
python-any-r1_pkg_setup
@@ -62,8 +56,7 @@ src_prepare() {
# Python is needed to run tests using lit
python_setup
- # User patches
- eapply_user
+ cmake-utils_src_prepare
}
src_configure() {
@@ -93,10 +86,6 @@ src_configure() {
# TODO: ocamldoc
)
- use test && mycmakeargs+=(
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
- )
-
cmake-utils_src_configure
local llvm_libdir=$(llvm-config --libdir)