summaryrefslogtreecommitdiff
path: root/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
index 3ded7e4e44fb..7f6ae880e2cb 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
@@ -8,8 +8,6 @@ inherit cmake llvm llvm.org python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( llvm )
-llvm.org_set_globals
# Keep in sync with sys-devel/llvm
ALL_LLVM_EXPERIMENTAL_TARGETS=( ARC CSKY VE )
@@ -17,7 +15,6 @@ ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM AVR BPF Hexagon Lanai Mips MSP430
NVPTX PowerPC RISCV Sparc SystemZ WebAssembly X86 XCore
"${ALL_LLVM_EXPERIMENTAL_TARGETS[@]}" )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
-LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0/${PV}"
@@ -29,8 +26,14 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-lang/ocaml-4.00.0:0=
dev-ml/ocaml-ctypes:=
- ~sys-devel/llvm-${PV}:=[${LLVM_TARGET_USEDEPS// /,},debug?]
+ ~sys-devel/llvm-${PV}:=[debug?]
!sys-devel/llvm[ocaml(-)]"
+for x in "${ALL_LLVM_TARGETS[@]}"; do
+ RDEPEND+="
+ ${x}? ( ~sys-devel/llvm-${PV}[${x}] )"
+done
+unset x
+
DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl
@@ -39,6 +42,9 @@ BDEPEND="
test? ( dev-ml/ounit )
${PYTHON_DEPS}"
+LLVM_COMPONENTS=( llvm )
+llvm.org_set_globals
+
pkg_setup() {
LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
python-any-r1_pkg_setup