summaryrefslogtreecommitdiff
path: root/dev-ml/jingoo/jingoo-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jingoo/jingoo-1.5.0.ebuild')
-rw-r--r--dev-ml/jingoo/jingoo-1.5.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/jingoo/jingoo-1.5.0.ebuild b/dev-ml/jingoo/jingoo-1.5.0.ebuild
new file mode 100644
index 000000000000..b9268dcbd0d8
--- /dev/null
+++ b/dev-ml/jingoo/jingoo-1.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml template engine almost compatible with Jinja2"
+HOMEPAGE="https://github.com/tategakibunko/jingoo/"
+SRC_URI="https://github.com/tategakibunko/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/menhir:=[ocamlopt?]
+ dev-ml/ppx_deriving:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/uucp:=
+ dev-ml/uutf:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"