summaryrefslogtreecommitdiff
path: root/dev-ml/gen/gen-1.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/gen/gen-1.0-r2.ebuild')
-rw-r--r--dev-ml/gen/gen-1.0-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/gen/gen-1.0-r2.ebuild b/dev-ml/gen/gen-1.0-r2.ebuild
new file mode 100644
index 000000000000..cc7656ab88d4
--- /dev/null
+++ b/dev-ml/gen/gen-1.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Iterators for OCaml, both restartable and consumable"
+HOMEPAGE="https://github.com/c-cube/gen/"
+SRC_URI="https://github.com/c-cube/gen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # tests fail > unused-open
+
+RDEPEND="
+ >=dev-lang/ocaml-4.07:=[ocamlopt?]
+ dev-ml/dune-configurator:=
+"
+DEPEND="${RDEPEND}"
+# BDEPEND="test? ( dev-ml/qtest )"