summaryrefslogtreecommitdiff
path: root/dev-ml/dune-configurator/dune-configurator-3.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/dune-configurator/dune-configurator-3.8.0.ebuild')
-rw-r--r--dev-ml/dune-configurator/dune-configurator-3.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/dune-configurator/dune-configurator-3.8.0.ebuild b/dev-ml/dune-configurator/dune-configurator-3.8.0.ebuild
new file mode 100644
index 000000000000..2ef2249b6a21
--- /dev/null
+++ b/dev-ml/dune-configurator/dune-configurator-3.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Helper library for gathering system configuration"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.5"
+DEPEND="
+ >=dev-ml/csexp-1.5:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # This enables dune-configurator to use the vendored csexp module
+ sed -i 's/stdune.csexp/dune-configurator.csexp/' \
+ vendor/csexp/src/dune || die
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}