summaryrefslogtreecommitdiff
path: root/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild')
-rw-r--r--dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild b/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild
new file mode 100644
index 000000000000..850c1001b9f1
--- /dev/null
+++ b/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+MY_P=ocaml-dns-${PV}
+
+DESCRIPTION="Lwt support of OCaml DNS"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/ocaml-dns/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/lwt:=
+ dev-ml/dns:=
+ dev-ml/mirage-profile:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ test? (
+ dev-ml/dns-lwt-unix
+ )
+ ${RDEPEND}
+"
+# do not work
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ jbuilder build @install -p ${PN} || die
+}
+
+src_test() {
+ jbuilder runtest -p ${PN} || die
+}