summaryrefslogtreecommitdiff
path: root/dev-ml/cstruct/cstruct-6.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/cstruct/cstruct-6.2.0.ebuild')
-rw-r--r--dev-ml/cstruct/cstruct-6.2.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/cstruct/cstruct-6.2.0.ebuild b/dev-ml/cstruct/cstruct-6.2.0.ebuild
new file mode 100644
index 000000000000..6d78859ac5fc
--- /dev/null
+++ b/dev-ml/cstruct/cstruct-6.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Access C-like structures directly from OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct"
+SRC_URI="https://github.com/mirage/ocaml-cstruct/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+src_compile() {
+ dune-compile ${PN}
+}