summaryrefslogtreecommitdiff
path: root/dev-ml/camlzip/camlzip-1.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlzip/camlzip-1.10.ebuild')
-rw-r--r--dev-ml/camlzip/camlzip-1.10.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-ml/camlzip/camlzip-1.10.ebuild b/dev-ml/camlzip/camlzip-1.10.ebuild
index 181f9c64d19a..244b689e332a 100644
--- a/dev-ml/camlzip/camlzip-1.10.ebuild
+++ b/dev-ml/camlzip/camlzip-1.10.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit findlib
-IUSE="+ocamlopt"
-
DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
HOMEPAGE="https://github.com/xavierleroy/camlzip"
SRC_URI="https://github.com/xavierleroy/camlzip/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
SLOT="1/${PV}"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
+IUSE="+ocamlopt"
RDEPEND=">=dev-lang/ocaml-4.05:=[ocamlopt?]
>=sys-libs/zlib-1.1.3"
@@ -24,8 +24,6 @@ QA_FLAGS_IGNORED=(
"/usr/lib.*/ocaml/zip/zip.cmxs"
)
-S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
-
src_compile() {
emake all
if use ocamlopt; then
@@ -35,6 +33,7 @@ src_compile() {
src_install() {
findlib_src_preinst
+
emake DESTDIR="${D}" install-findlib
dosym zip/libcamlzip.a /usr/$(get_libdir)/ocaml/libcamlzip.a