summaryrefslogtreecommitdiff
path: root/dev-ml/camlidl/camlidl-1.05-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlidl/camlidl-1.05-r1.ebuild')
-rw-r--r--dev-ml/camlidl/camlidl-1.05-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-ml/camlidl/camlidl-1.05-r1.ebuild b/dev-ml/camlidl/camlidl-1.05-r1.ebuild
deleted file mode 100644
index d7cbca3f978e..000000000000
--- a/dev-ml/camlidl/camlidl-1.05-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
-HOMEPAGE="http://caml.inria.fr/camlidl/"
-SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
-
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-
-DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/tests.patch"
- "${FILESDIR}/includes.patch"
- "${FILESDIR}/nowarn.patch"
-)
-
-src_prepare() {
- sed -i \
- -e "s|ar rc|$(tc-getAR) rc|g" \
- runtime/Makefile.unix \
- || die
- default
-}
-
-src_compile() {
- # Use the UNIX makefile
- libdir=$(ocamlc -where || die)
-
- sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix || die
- sed -i -e "s|BINDIR=.*|BINDIR=${EPREFIX}/usr/bin|" config/Makefile.unix || die
- ln -s Makefile.unix config/Makefile || die
-
- # Make
- emake -j1 RANLIB="$(tc-getRANLIB)"
-}
-
-src_test() {
- einfo "Running tests..."
- cd tests || die
- emake CCPP="$(tc-getCXX)"
-}
-
-src_install() {
- libdir=$(ocamlc -where || die)
- dodir "${libdir#${EPREFIX}}"/caml
-
- dodir /usr/bin
- # Install
- emake BINDIR="${ED}/usr/bin" OCAMLLIB="${D}${libdir}" RANLIB="$(tc-getRANLIB)" install
-
- # Add package header
- sed -e "s/@VERSION/${P}/g" "${FILESDIR}/META.camlidl" > "${D}${libdir}/META.camlidl" || die
-
- # Documentation
- dodoc README Changes
-}