summaryrefslogtreecommitdiff
path: root/dev-ml/camldbm/camldbm-1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camldbm/camldbm-1.0.ebuild')
-rw-r--r--dev-ml/camldbm/camldbm-1.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-ml/camldbm/camldbm-1.0.ebuild b/dev-ml/camldbm/camldbm-1.0.ebuild
index 5286f0873c34..8f8d8b94854c 100644
--- a/dev-ml/camldbm/camldbm-1.0.ebuild
+++ b/dev-ml/camldbm/camldbm-1.0.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit base
+EAPI=7
DESCRIPTION="OCaml binding to the NDBM/GDBM Unix databases"
HOMEPAGE="http://forge.ocamlcore.org/projects/camldbm/"
@@ -12,13 +10,15 @@ SRC_URI="http://forge.ocamlcore.org/frs/download.php/728/${P}.tgz"
LICENSE="LGPL-2-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="amd64 arm ppc x86"
-IUSE=""
DEPEND=">=sys-libs/gdbm-1.9.1-r2[berkdb]
>=dev-lang/ocaml-3.12:=[ocamlopt]"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/hasgotfix.patch" "${FILESDIR}/include_fix.patch" )
+PATCHES=(
+ "${FILESDIR}/hasgotfix.patch"
+ "${FILESDIR}/include_fix.patch"
+)
src_install() {
dodir "$(ocamlc -where)/stublibs" # required and makefile does not create it