summaryrefslogtreecommitdiff
path: root/dev-ml/angstrom-async/angstrom-async-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/angstrom-async/angstrom-async-0.7.0.ebuild')
-rw-r--r--dev-ml/angstrom-async/angstrom-async-0.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/angstrom-async/angstrom-async-0.7.0.ebuild b/dev-ml/angstrom-async/angstrom-async-0.7.0.ebuild
new file mode 100644
index 000000000000..d67309411be2
--- /dev/null
+++ b/dev-ml/angstrom-async/angstrom-async-0.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Parser combinators built for speed and memory efficiency"
+HOMEPAGE="https://github.com/inhabitedtype/angstrom"
+SRC_URI="https://github.com/inhabitedtype/angstrom/archive/${PV}.tar.gz -> angstrom-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/angstrom:=
+ dev-ml/async:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder"
+
+S="${WORKDIR}/angstrom-${PV}"
+
+src_compile() {
+ jbuilder build -p ${PN} || die
+}
+
+src_test() {
+ jbuilder runtest -p ${PN}
+}