summaryrefslogtreecommitdiff
path: root/dev-ml/alcotest/alcotest-1.5.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/alcotest/alcotest-1.5.0-r1.ebuild')
-rw-r--r--dev-ml/alcotest/alcotest-1.5.0-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-ml/alcotest/alcotest-1.5.0-r1.ebuild b/dev-ml/alcotest/alcotest-1.5.0-r1.ebuild
index 9d4860fa648d..7e2047961acc 100644
--- a/dev-ml/alcotest/alcotest-1.5.0-r1.ebuild
+++ b/dev-ml/alcotest/alcotest-1.5.0-r1.ebuild
@@ -12,7 +12,8 @@ SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="+ocamlopt"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-ml/dune-2.8:=
@@ -31,3 +32,11 @@ RDEPEND="
dev-ml/uuidm:=
"
DEPEND="${RDEPEND}"
+BDEPEND="test? ( >=dev-ml/cmdliner-1.1.0 )"
+
+src_prepare() {
+ cp "${FILESDIR}"/unknown_option.processed \
+ test/e2e/alcotest/failing/unknown_option.expected \
+ || die
+ default
+}