summaryrefslogtreecommitdiff
path: root/dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch')
-rw-r--r--dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch b/dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch
new file mode 100644
index 000000000000..d9c324935b91
--- /dev/null
+++ b/dev-lua/luv/files/luv-1.43.0.0-cmake_lua_version.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 78c0345..853ba90 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -140,7 +140,7 @@ else (LUA)
+ if (WIN32)
+ find_package(Lua REQUIRED)
+ else()
+- find_package(Lua)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ endif()
+ if(NOT LUA_INCLUDE_DIR)
+ message( FATAL_ERROR "Failed to find Lua headers. Variable `LUA_INCLUDE_DIR' expected to be defined.")