summaryrefslogtreecommitdiff
path: root/dev-lua/luarocks
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luarocks')
-rw-r--r--dev-lua/luarocks/Manifest2
-rw-r--r--dev-lua/luarocks/luarocks-3.10.0.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index ef76f3087817..0ae22c05093c 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,3 +1,5 @@
+DIST luarocks-3.10.0.tar.gz 273518 BLAKE2B 64a9f7d5c9e15b8753e32f080d8f792be37f7b66635ce3df2218563774d5f90a18ef1b625861e13df9e728e1cbd90f0ed7247ce1bec207b97fa895780a77ab53 SHA512 4a834059b8f544274a110131d59d0647fb317078ef7709c1dc1a464513ebc38300abb71094620e21bb2f6e60193e9a1b0c06e7e0f4ad9acc2bf188bf4b599922
DIST luarocks-3.9.2.tar.gz 256117 BLAKE2B eebbad38dd71b0318852a177d394df5fd20e807d566893a2338526e76e17daf2436309e512dd50b325914b2d84b90ef857396bfd6d41f22893131ed78931b8ad SHA512 7e93164bdcf35338e993822931a8e59957ab69c6e23236a7a075649c2f7cd173305c4ca6e9d115fc5e282cb76c21754d7adac92b21885006e5ee3bc06a9d0059
+EBUILD luarocks-3.10.0.ebuild 2036 BLAKE2B 3427ddeaa484b3a105ce82c8ffec458ea957f44deb009f9c40e92dc24927ae5e5870a3739e53ee7b0991adb087d0a924a51738c593cde8091e0298c7fd275ad5 SHA512 48337d673725cb494fd6bc79a770fd9a5b67c785d11c7b1a17ff8107b3a05b57229eac079f109a0929df4949baee403e298b3a16c64784b38123a4da4e20fef8
EBUILD luarocks-3.9.2.ebuild 2032 BLAKE2B 734eb895b3d1005336cb528b212e2eb2283b5092fee5566c7479b512f5ff3513860163564b13d233c852bef812c5b6410f95ba7739af57ec6f6dcb270e8cea0f SHA512 3ab41e559dbd2fbab1505981eb98eb159de506f16ba6b239b80db9c23caf95fc2d3f59ee283816573335407df99f10a3d9f93cd91ea559c53e179405f16f846f
MISC metadata.xml 501 BLAKE2B 0a2a3e7358a2ef2a4cbb79853408dfdf6015d49348bbb879a59253a88c73cf3d96c2ce708076844344468136d70962be74e639d24331a007fbd02ce6ccc18cee SHA512 43f147be67209e542e02733b6a57ce7ee05b61a7eb0d15662c0fb137db4f57c9f519cc98cf5dceb0e6f626f0dc6f04dd5b67da96a155b1e3884dca55896722f3
diff --git a/dev-lua/luarocks/luarocks-3.10.0.ebuild b/dev-lua/luarocks/luarocks-3.10.0.ebuild
new file mode 100644
index 000000000000..2319a20303e0
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-3.10.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="A package manager for the Lua programming language"
+HOMEPAGE="https://luarocks.org"
+SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ default
+
+ # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
+ # as no compiled modules are installed on a new, fresh installation,
+ # so this check must be disabled, otherwise 'configure' will fail.
+ sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--prefix=${EPREFIX}/usr"
+ "--rocks-tree=$(lua_get_lmod_dir)"
+ "--with-lua-include=$(lua_get_include_dir)"
+ "--with-lua-interpreter=${ELUA}"
+ "--with-lua-lib=$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+}
+
+src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_install() {
+ default
+
+ { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
+}
+
+pkg_postinst() {
+ local lua_abi_ver
+ if use lua_single_target_luajit; then
+ lua_abi_ver="5.1"
+ else
+ lua_abi_ver=${ELUA#lua}
+ fi
+ elog
+ elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
+ elog "you can use the command-line option --lua-version, e.g."
+ elog
+ elog " luarocks --lua-version 5.3 install luasocket"
+ elog
+ elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
+ elog
+}