summaryrefslogtreecommitdiff
path: root/dev-lua/luarocks/luarocks-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luarocks/luarocks-2.2.0.ebuild')
-rw-r--r--dev-lua/luarocks/luarocks-2.2.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-lua/luarocks/luarocks-2.2.0.ebuild b/dev-lua/luarocks/luarocks-2.2.0.ebuild
deleted file mode 100644
index 5a450c989c0d..000000000000
--- a/dev-lua/luarocks/luarocks-2.2.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils multilib
-
-DESCRIPTION="A deployment and management system for Lua modules"
-HOMEPAGE="http://www.luarocks.org"
-SRC_URI="http://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="curl openssl"
-
-DEPEND="dev-lang/lua
- curl? ( net-misc/curl )
- openssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}
- app-arch/unzip"
-
-src_configure() {
- USE_MD5="md5sum"
- USE_FETCH="wget"
- use openssl && USE_MD5="openssl"
- use curl && USE_FETCH="curl"
-
- # econf doesn't work b/c it passes variables the custom configure can't
- # handle
- ./configure \
- --prefix=/usr \
- --with-lua-lib=/usr/$(get_libdir) \
- --rocks-tree=/usr/$(get_libdir)/lua/luarocks \
- --with-downloader=$USE_FETCH \
- --with-md5-checker=$USE_MD5 \
- || die "configure failed"
-}
-
-src_compile() {
- # -j1 b/c make tries to delete files it has yet to create (bug #402005)
- emake DESTDIR="${D}" -j1
-}
-
-src_install() {
- # -j1 b/c otherwise it fails to find src/bin/luarocks
- emake DESTDIR="${D}" -j1 install
-}
-
-pkg_preinst() {
- find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
-}