summaryrefslogtreecommitdiff
path: root/dev-lua/lgi/lgi-0.9.2-r100.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lgi/lgi-0.9.2-r100.ebuild')
-rw-r--r--dev-lua/lgi/lgi-0.9.2-r100.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-lua/lgi/lgi-0.9.2-r100.ebuild b/dev-lua/lgi/lgi-0.9.2-r100.ebuild
index 8c362af8788a..4fab943f27a6 100644
--- a/dev-lua/lgi/lgi-0.9.2-r100.ebuild
+++ b/dev-lua/lgi/lgi-0.9.2-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -97,9 +97,14 @@ src_compile() {
lua_src_test() {
pushd "${BUILD_DIR}" || die
- virtx \
- lgi_emake_wrapper \
- check
+
+ if [[ ${ELUA} == luajit ]]; then
+ einfo "Tests are currently not supported on LuaJIT"
+ else
+ virtx \
+ lgi_emake_wrapper \
+ check
+ fi
popd
}