summaryrefslogtreecommitdiff
path: root/dev-lua/inifile/inifile-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/inifile/inifile-1.1.ebuild')
-rw-r--r--dev-lua/inifile/inifile-1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lua/inifile/inifile-1.1.ebuild b/dev-lua/inifile/inifile-1.1.ebuild
new file mode 100644
index 000000000000..8e3abb13bd5f
--- /dev/null
+++ b/dev-lua/inifile/inifile-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="A simple and complete ini parser for Lua"
+HOMEPAGE="https://github.com/bartbes/inifile/"
+SRC_URI="https://github.com/bartbes/inifile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+BDEPEND="virtual/pkgconfig"
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins inifile.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}