summaryrefslogtreecommitdiff
path: root/dev-lisp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/alexandria/Manifest4
-rw-r--r--dev-lisp/alexandria/alexandria-20171029.ebuild39
-rw-r--r--dev-lisp/alexandria/files/alexandria-fix-docstrings.patch29
-rw-r--r--dev-lisp/alexandria/metadata.xml44
-rw-r--r--dev-lisp/asdf/Manifest2
-rw-r--r--dev-lisp/asdf/asdf-3.3.0.ebuild4
6 files changed, 119 insertions, 3 deletions
diff --git a/dev-lisp/alexandria/Manifest b/dev-lisp/alexandria/Manifest
new file mode 100644
index 000000000000..1f9a5a38971c
--- /dev/null
+++ b/dev-lisp/alexandria/Manifest
@@ -0,0 +1,4 @@
+AUX alexandria-fix-docstrings.patch 1128 SHA256 f0ebfee56013d2adc46ae2027f6b324d2888b787e14478a76dcf33a439e7bf1d SHA512 04b80319839f3f39f1156a7604eb2565419a203e9c5520f6fd773f1865b57bade58e13769a26c03292ef666839b89fd5abb6dd5f952718513449f4862be5d2e9 WHIRLPOOL fa25f376066000e64978921b07e1bb57ddf5116349b1dfe51c7e2049e2e187c7992e6b5b2732b00910d9023582e9fb1ab491460e2795d60144db68497a88ca77
+DIST alexandria-20171029.tar.bz2 45812 SHA256 03941516cb60344a505f6e4c9a323ad3ca7f4b64a6984452c6d0a5bc94cb99c1 SHA512 a0a7386af94bae00139e3d06306169883cb1c5498c84d7a6db552a5dfa2ff8516d62609cb8a059c11f4200d507737ba99032d81b5a97112a2f3e7850572060e2 WHIRLPOOL d5c13ff07f3602d6697a5d7165d7ab0b261e93364ff53287fa308db237d93a2abdd94cb4d5aa5784bef19a8443670ace9c5149be8876bed0f70ab277f3f446f4
+EBUILD alexandria-20171029.ebuild 879 SHA256 8b5d7f4a576b3d3f9119e08aea1a64ad389b617a6a54adbade29e6b467ccfee1 SHA512 60ab44f59f228537ebde62f1c626664e2b11044e29207a18810b70b54c39a4f34de5e536b0f397e5f699de248f71e2dd43cc5a561eafc606c07d7fab93d1773c WHIRLPOOL ae71b88cd6fb95970c50a80353d1e040992e07048ffe799ee982df2c9d79aef0b39dba1be61696dd30a9806f3a742c5aacddd59e0164b2c82da8559716ec82a4
+MISC metadata.xml 2284 SHA256 ae854aadac92d2c4b269a891c95f08d8501108740d206337a704babb862773f4 SHA512 b7bcb6e83349e84327ca1b07eb3645b9a682bd8fb0d39569e0c868c9b075cdea4c50101697e354952e64216e1a65617072d137ef2a683bab81afa1d889075838 WHIRLPOOL 379da00f485c248fb230a78f50801bd7812335522ec25d73297488cca74a476a9dcb627b2b605192f3c927e8fa5b2608148c710d1d03728b0b74879b08ebe7bc
diff --git a/dev-lisp/alexandria/alexandria-20171029.ebuild b/dev-lisp/alexandria/alexandria-20171029.ebuild
new file mode 100644
index 000000000000..bd042f0736f8
--- /dev/null
+++ b/dev-lisp/alexandria/alexandria-20171029.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3 eutils
+
+DESCRIPTION="A collection of portable utilities for Common Lisp"
+HOMEPAGE="http://common-lisp.net/project/alexandria/"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.common-lisp.net/alexandria/alexandria.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="doc? ( sys-apps/texinfo )"
+RDEPEND=""
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-fix-docstrings.patch"
+ eapply_user
+}
+
+src_compile() {
+ use doc && emake -C doc
+}
+
+src_install() {
+ common-lisp-install-sources -t all *.lisp LICENCE
+ common-lisp-install-asdf
+ dodoc README AUTHORS
+ use doc && doinfo doc/${PN}.info && dodoc doc/{"${PN}.html","${PN}.pdf"}
+}
diff --git a/dev-lisp/alexandria/files/alexandria-fix-docstrings.patch b/dev-lisp/alexandria/files/alexandria-fix-docstrings.patch
new file mode 100644
index 000000000000..747c9e3bf59d
--- /dev/null
+++ b/dev-lisp/alexandria/files/alexandria-fix-docstrings.patch
@@ -0,0 +1,29 @@
+diff -Nuar a/doc/docstrings.lisp b/doc/docstrings.lisp
+--- a/doc/docstrings.lisp 2016-12-11 00:04:21.272877121 +0100
++++ b/doc/docstrings.lisp 2016-12-11 00:05:03.752876882 +0100
+@@ -718,7 +718,7 @@
+ ;; sbcl.texinfo defines macros that expand @&key and friends to &key.
+ (mapcar (lambda (name)
+ (if (member name lambda-list-keywords)
+- (format nil "@~A" name)
++ (format nil "~A" name)
+ name))
+ (lambda-list doc)))))
+
+@@ -833,11 +833,11 @@
+ (flet ((macro (name)
+ (let ((string (string-downcase name)))
+ (format *texinfo-output* "@macro ~A~%~A~%@end macro~%" string string))))
+- (macro '&allow-other-keys)
+- (macro '&optional)
+- (macro '&rest)
+- (macro '&key)
+- (macro '&body)))
++ (macro 'allow-other-keys)
++ (macro 'optional)
++ (macro 'rest)
++ (macro 'key)
++ (macro 'body)))
+
+ (defun generate-includes (directory packages &key (base-package :cl-user))
+ "Create files in `directory' containing Texinfo markup of all
diff --git a/dev-lisp/alexandria/metadata.xml b/dev-lisp/alexandria/metadata.xml
new file mode 100644
index 000000000000..937bb81734f3
--- /dev/null
+++ b/dev-lisp/alexandria/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Alexandria is a project and a library.
+
+ As a project Alexandria's goal is to reduce duplication of effort and
+ improve portability of Common Lisp code according to its own
+ idiosyncratic and rather conservative aesthetic. What this actually
+ means is open to debate, but each project member has a veto on all
+ project activities, so a degree of conservativism is inevitable.
+
+ As a library Alexandria is one of the means by which the project
+ strives for its goals. Alexandria is a collection of portable public
+ domain utilities that meet the following constraints:
+
+ * Utilities, not extensions: Alexandria will not contain conceptual
+ extensions to Common Lisp, instead limiting itself to tools and
+ utilities that fit well within the framework of standard ANSI Common
+ Lisp. Test-frameworks, system definitions, logging facilities,
+ serialization layers, etc. are all outside the scope of Alexandria
+ as a library, though well within the scope of Alexandria as a project.
+ * Conservative: Alexandria limits itself to what project members
+ consider conservative utilities. Alexandria does not and will not
+ include anaphoric constructs, loop-like binding macros, etc.
+ * Portable: Alexandria limits itself to portable parts of Common
+ Lisp. Even apparently conservative and usefull functions remain
+ outside the scope of Alexandria if they cannot be implemented
+ portably. Portability is here defined as portable within a
+ conforming implementation: implementation bugs are not considered
+ portability issues.
+ * Team player: Alexandria will not (initially, at least) subsume
+ or provide functionality for which good-quality special-purpose
+ packages exist, like split-sequence. Instead, third party packages
+ such as that may be "blessed".
+ </longdescription>
+ <upstream>
+ <remote-id type="gitlab">alexandria/alexandria</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lisp/asdf/Manifest b/dev-lisp/asdf/Manifest
index 03702721b544..d27ee5c7a825 100644
--- a/dev-lisp/asdf/Manifest
+++ b/dev-lisp/asdf/Manifest
@@ -18,7 +18,7 @@ EBUILD asdf-3.2.0-r1.ebuild 1217 SHA256 6a330421ea7a4186943f46a1bdff008dd5ac563a
EBUILD asdf-3.2.0.ebuild 1180 SHA256 dca374f2f464fb8128062d9a4a7cfd29ca20f805c5a63ba137660db9ee3233e9 SHA512 7b8ba0ddf907f715c34f296f88fe0332cbe69b051304b5a61647411c7c3ca9d0fb8267d18d8301472a4152e10d3e65281cd616f92746dbd888ed379cd0dc1cb8 WHIRLPOOL 2502ab62e7dce45b06f0cc378a464ea1d83b82c68451b940d7e7c4df8e47b53e481f50caafe4dace57784789344b3cf2debc6939299afba3649216f294227dcc
EBUILD asdf-3.2.1-r1.ebuild 1565 SHA256 6574c1e0c4d265433f4e5ab4252fa5a8f72e61ed57081bbf0818b578a0ffef58 SHA512 3832123b0ae4f5e99aa8603aa3165a61537ebd807ab9755dd7136d1adbe1fe593bfe2988f4e26814171909dd16923b77e1f445a42b5e2739e15cec0869076617 WHIRLPOOL cf1a07dd31d80e4e87d1efa0ff668adf030cfbf52ed8833550e82d2744a336e4547bbc682a742ff94a9a8ebf687a7492c8871c4b6b9b57361d22f1d51c197655
EBUILD asdf-3.2.1.ebuild 1217 SHA256 6a330421ea7a4186943f46a1bdff008dd5ac563a94f3e038dc8ae2b4bcbba154 SHA512 324b8406d9955edda267ab00f34d6e97fd490d48184d8c8bc925b63f73737d207b85a7b29770eb02388bdb07a9ef8d77fb7633b8cccc48dea43bcf1b4067725b WHIRLPOOL ade6a3f2c7f86f3700f392de58fd46ca9a049185a9d53d0e19cd8ab8f6c37960485ed24c81dab4f1b5bdd995aaf44633cc0354237f7c03eb6e33c79dbfa06cc6
-EBUILD asdf-3.3.0.ebuild 1374 SHA256 359d77737db1908e170c9c6a4e8f25082919904ca2727888f6f92cbdeb82d98f SHA512 e2dd74be50a34642d3cf6199ea6513254e6416c2a8399d13f273632953691728d7cb50c597891a375aef82d04ac2c680a854c816b976d6bba34f66eec49afdf1 WHIRLPOOL d8b5af5249f60205554bb17165241a68a5ff96b5df6f72f03b972037f48f7036074ae111b925ad226bdfcbf3f4d6334913e9b08c751e048265520f8a57545090
+EBUILD asdf-3.3.0.ebuild 1366 SHA256 6d3b77283c61b4c1104c80b176444c787d3f10086be601c5c29da9836e82a5d8 SHA512 9be27455ed41c2e74a3f9100cdd70ef65789305182e948e4a7a618a7df55347c208a7f3532688ddeadb4a204fbddcc92ce7ffe8488a554024b7cfafbbda29b56 WHIRLPOOL 36fcc6510f6552d1ce6fdebd6eb263dbd9db2298d5fb997642102796fd2344a0649f9270bf9135d8a6a6d823be69b8e863333307a922a087dc239fd89d76a62c
MISC ChangeLog 3794 SHA256 8dd8375a341d0887e5e5f7c698b8f4483fd9da73927cdbb11a3093a04fac167d SHA512 ea5e83f11849e64b1390f0f33dbe9e5a2ee4266aa90cd94a188bb9cf9a4fc9044b483d4c0879e81bcbe2199027ceed46a2522e7b486484143cc9f6c8fe92a38e WHIRLPOOL ba5b6e9222b3b912c5f86c8ebd572fafdcb92ae82125d05d0c1c78c56620d4aab0824161eb4da711a232a71fc93bcdc17e44732d731471b9e090b59003074291
MISC ChangeLog-2015 7148 SHA256 7e32561a57899ee6e5bb5f43d6db4d9a208a6aaabf018e233edfa8adb009d83e SHA512 0c0d65ecbd4b82f4c82fa52370cb2d6813eda9ef8ed2f9a956340da7e19e947eb181e5ac4297903b2c4fbfea099970a4c2b8a24446ab50b96ca6e0d626afed8d WHIRLPOOL 73084a5ac71679827d448b98497b6c78026aef4056a649724c2c9a08bfb8c1f6b1fe5608644d6bb76927d4c359db5da36c3c17a68c4ce7dcbe5bd2b04a40ef1f
MISC metadata.xml 261 SHA256 627a8fb846aff40f2f1e29e77040baa5b21fd7663158ab97b84012e0b5e2f742 SHA512 fb754c4ed3579db5dbe303197a05647b7cfab0a3fe47fd2140d5f77641be752d10ccf49a9c267406a0f3ba3dcda8831f778b9596d723f65aff10142bfad60d3d WHIRLPOOL 02fb9a9a64cd705025462ef7601b9b452954c62e41f57422a5a74e6e0c84695aca510635335b0cf35031dfbe75142c0feb06ce1ba4f2794c6230378d772c3ae3
diff --git a/dev-lisp/asdf/asdf-3.3.0.ebuild b/dev-lisp/asdf/asdf-3.3.0.ebuild
index 7e5f5cda6229..ecced8bc873a 100644
--- a/dev-lisp/asdf/asdf-3.3.0.ebuild
+++ b/dev-lisp/asdf/asdf-3.3.0.ebuild
@@ -21,8 +21,8 @@ DEPEND="!dev-lisp/cl-${PN}
!dev-lisp/gentoo-init
!<dev-lisp/asdf-2.33-r3
doc? ( virtual/texi2dvi )"
-RDEPEND="virtual/commonlisp"
-PDEPEND="~dev-lisp/uiop-${PV}"
+PDEPEND="virtual/commonlisp
+ ~dev-lisp/uiop-${PV}"
install_docs() {
(cd doc ; dodoc *.{html,css,ico,png} "${PN}.pdf" ; dodoc -r asdf )