summaryrefslogtreecommitdiff
path: root/dev-libs/wayland/wayland-1.15.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/wayland/wayland-1.15.0.ebuild')
-rw-r--r--dev-libs/wayland/wayland-1.15.0.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-libs/wayland/wayland-1.15.0.ebuild b/dev-libs/wayland/wayland-1.15.0.ebuild
deleted file mode 100644
index e13f0b8db1a4..000000000000
--- a/dev-libs/wayland/wayland-1.15.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-inherit autotools libtool ltprune multilib-minimal toolchain-funcs $GIT_ECLASS
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/"
-
-if [[ $PV = 9999* ]]; then
- SRC_URI=""
-else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
- dev-libs/libxml2:=
- !<media-libs/mesa-18.1.1-r1"
-DEPEND="${RDEPEND}
- doc? (
- >=app-doc/doxygen-1.6[dot]
- app-text/xmlto
- >=media-gfx/graphviz-2.26.0
- sys-apps/grep[pcre]
- )
- virtual/pkgconfig"
-
-src_prepare() {
- default
- [[ $PV = 9999* ]] && eautoreconf || elibtoolize
-}
-
-multilib_src_configure() {
- local myconf
- if tc-is-cross-compiler ; then
- myconf+=' --with-host-scanner '
- fi
-
- ECONF_SOURCE="${S}" econf \
- --disable-static \
- $(multilib_native_use_enable doc documentation) \
- $(multilib_native_enable dtd-validation) \
- ${myconf}
-}
-
-multilib_src_install_all() {
- prune_libtool_files
- einstalldocs
-}
-
-src_test() {
- # We set it on purpose to only a short subdir name, as socket paths are
- # created in there, which are 108 byte limited. With this it hopefully
- # barely fits to the limit with /var/tmp/portage/$CAT/$PF/temp/xdr
- export XDG_RUNTIME_DIR="${T}"/xdr
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- multilib-minimal_src_test
-}