summaryrefslogtreecommitdiff
path: root/dev-libs/wayland/wayland-1.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/wayland/wayland-1.12.0.ebuild')
-rw-r--r--dev-libs/wayland/wayland-1.12.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-libs/wayland/wayland-1.12.0.ebuild b/dev-libs/wayland/wayland-1.12.0.ebuild
deleted file mode 100644
index 5d1f9f422866..000000000000
--- a/dev-libs/wayland/wayland-1.12.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland.git"
- GIT_ECLASS="git-r3"
- EXPERIMENTAL="true"
- AUTOTOOLS_AUTORECONF=1
-fi
-
-inherit autotools-multilib toolchain-funcs $GIT_ECLASS
-
-DESCRIPTION="Wayland protocol libraries"
-HOMEPAGE="https://wayland.freedesktop.org/"
-
-if [[ $PV = 9999* ]]; then
- SRC_URI="${SRC_PATCHES}"
-else
- SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
- >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]
- dev-libs/libxml2:="
-DEPEND="${RDEPEND}
- doc? (
- >=app-doc/doxygen-1.6[dot]
- app-text/xmlto
- >=media-gfx/graphviz-2.26.0
- sys-apps/grep[pcre]
- )
- virtual/pkgconfig"
-
-multilib_src_configure() {
- local myeconfargs=(
- $(multilib_native_use_enable doc documentation)
- $(multilib_native_enable dtd-validation)
- )
- if tc-is-cross-compiler ; then
- myeconfargs+=( --with-host-scanner )
- fi
-
- autotools-utils_src_configure
-}
-
-src_test() {
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- autotools-multilib_src_test
-}