summaryrefslogtreecommitdiff
path: root/dev-libs/trio/trio-1.17.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/trio/trio-1.17.1.ebuild')
-rw-r--r--dev-libs/trio/trio-1.17.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/trio/trio-1.17.1.ebuild b/dev-libs/trio/trio-1.17.1.ebuild
new file mode 100644
index 000000000000..251a5eeee761
--- /dev/null
+++ b/dev-libs/trio/trio-1.17.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc"
+
+inherit docs
+
+DESCRIPTION="Portable string functions, focus on the *printf() and *scanf() clones"
+HOMEPAGE="https://daniel.haxx.se/projects/trio/"
+SRC_URI="https://github.com/orbea/trio/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="trio"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ default
+ docs_compile
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}