summaryrefslogtreecommitdiff
path: root/dev-libs/tlsh/tlsh-4.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tlsh/tlsh-4.8.2.ebuild')
-rw-r--r--dev-libs/tlsh/tlsh-4.8.2.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/tlsh/tlsh-4.8.2.ebuild b/dev-libs/tlsh/tlsh-4.8.2.ebuild
index dc63ec1c565a..8b6e02c5e549 100644
--- a/dev-libs/tlsh/tlsh-4.8.2.ebuild
+++ b/dev-libs/tlsh/tlsh-4.8.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
CMAKE_IN_SOURCE_BUILD=1
-inherit cmake
+inherit cmake toolchain-funcs flag-o-matic
DESCRIPTION="Fuzzy matching library"
HOMEPAGE="https://github.com/trendmicro/tlsh"
@@ -19,6 +19,12 @@ PATCHES=(
"${FILESDIR}"/${P}-respect-flags.patch
)
+src_prepare() {
+ # https://github.com/trendmicro/tlsh/issues/131
+ [[ "$(tc-endian)" == "big" ]] && append-flags "-D__SPARC"
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DTLSH_CHECKSUM_1B=1