summaryrefslogtreecommitdiff
path: root/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild')
-rw-r--r--dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild b/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild
new file mode 100644
index 000000000000..57a8d746e1b2
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-7.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=( -DBUILD_TESTING=$(usex test) )
+ cmake-utils_src_configure
+}