summaryrefslogtreecommitdiff
path: root/dev-libs/template-glib/template-glib-3.36.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/template-glib/template-glib-3.36.1.ebuild')
-rw-r--r--dev-libs/template-glib/template-glib-3.36.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-libs/template-glib/template-glib-3.36.1.ebuild b/dev-libs/template-glib/template-glib-3.36.1.ebuild
deleted file mode 100644
index 52a0c01b99f1..000000000000
--- a/dev-libs/template-glib/template-glib-3.36.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org meson vala
-
-DESCRIPTION="Templating library for GLib"
-HOMEPAGE="https://gitlab.gnome.org/GNOME/template-glib"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/1"
-KEYWORDS="amd64 ~arm64 x86"
-
-IUSE="gtk-doc +introspection test vala"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="vala? ( introspection )"
-
-RDEPEND="
- dev-libs/glib:2
- dev-libs/gobject-introspection:=
-" # depends on go-i unconditionally for own functionality, USE flag controls GIR/typelib generation
-DEPEND="${RDEPEND}"
-BDEPEND="
- vala? ( $(vala_depend) )
- dev-util/glib-utils
- app-alternatives/yacc
- app-alternatives/lex
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
- gtk-doc? ( dev-util/gtk-doc )
-"
-
-src_prepare() {
- default
- use vala && vala_setup
-}
-
-src_configure() {
- local emesonargs=(
- -Dtracing=false # extra trace debugging that would make things slower
- -Dprofiling=false # -pg passing
- $(meson_feature introspection)
- $(meson_use vala vapi)
- $(meson_use gtk-doc gtk_doc)
- $(meson_use test tests)
- )
- meson_src_configure
-}