summaryrefslogtreecommitdiff
path: root/dev-libs/stb/stb-20240201.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/stb/stb-20240201.ebuild')
-rw-r--r--dev-libs/stb/stb-20240201.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/stb/stb-20240201.ebuild b/dev-libs/stb/stb-20240201.ebuild
new file mode 100644
index 000000000000..a7606445ce4e
--- /dev/null
+++ b/dev-libs/stb/stb-20240201.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# There are no official releases
+CHECKSUM="f4a71b13373436a2866c5d68f8f80ac6f0bc1ffe"
+
+DESCRIPTION="single-file public domain (or MIT licensed) libraries for C/C++"
+HOMEPAGE="https://github.com/nothings/stb"
+SRC_URI="https://github.com/nothings/stb/archive/${CHECKSUM}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+S="${WORKDIR}/${PN}-${CHECKSUM}"
+
+src_prepare() {
+ default
+
+ # Move the header files in a folder so they don't pollute the include dir
+ mkdir stb || die
+ mv *.h stb/ || die
+}
+
+src_install() {
+ doheader -r stb
+
+ insinto /usr/share/pkgconfig
+ cat > "${D}"/usr/share/pkgconfig/stb.pc <<-EOF
+ prefix=/usr
+ includedir=\${prefix}/include/stb
+
+ Name: stb
+ Description: stb single-file public domain libraries
+ Version: ${PV}
+ Cflags: -I\${includedir}
+ EOF
+}