summaryrefslogtreecommitdiff
path: root/dev-libs/spdlog/spdlog-0.14.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/spdlog/spdlog-0.14.0-r1.ebuild')
-rw-r--r--dev-libs/spdlog/spdlog-0.14.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/spdlog/spdlog-0.14.0-r1.ebuild b/dev-libs/spdlog/spdlog-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..0118dd39d236
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-0.14.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library."
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # root CMakeLists.txt is CRLF line terminated, so...
+ cp "${FILESDIR}"/${P}-CMakeLists.txt CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_TESTING=$(usex test)
+ )
+
+ cmake-utils_src_configure
+
+}