summaryrefslogtreecommitdiff
path: root/dev-libs/simde/simde-0.7.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/simde/simde-0.7.6-r1.ebuild')
-rw-r--r--dev-libs/simde/simde-0.7.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/simde/simde-0.7.6-r1.ebuild b/dev-libs/simde/simde-0.7.6-r1.ebuild
new file mode 100644
index 000000000000..2a963a57dd1e
--- /dev/null
+++ b/dev-libs/simde/simde-0.7.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Header-only library providing implementations of SIMD instruction sets"
+HOMEPAGE="https://simd-everywhere.github.io/blog/"
+SRC_URI="
+ https://github.com/simd-everywhere/simde/archive/refs/tags/v${PV/_/-}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.6-musl.patch
+)
+
+src_configure() {
+ # *FLAGS are only used for tests (nothing that is installed), and
+ # upstream tests with specific *FLAGS and is otherwise flaky with
+ # -march=native, -mno-*, and such -- unset to be spared headaches.
+ unset {C,CPP,CXX,LD}FLAGS
+
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}