summaryrefslogtreecommitdiff
path: root/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/shhopt/shhopt-1.1.7-r3.ebuild')
-rw-r--r--dev-libs/shhopt/shhopt-1.1.7-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild b/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
new file mode 100644
index 000000000000..83fb8b878ace
--- /dev/null
+++ b/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="library for parsing command line options"
+HOMEPAGE="http://shh.thathost.com/pub-unix/"
+SRC_URI="http://shh.thathost.com/pub-unix/files/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dolib.a libshhopt.a
+ ln -s libshhopt.so.${PV} libshhopt.so || die
+ ln -s libshhopt.so.${PV} libshhopt.so.${PV:0:1} || die
+ dolib.so libshhopt.so*
+ doheader shhopt.h
+ dodoc ChangeLog CREDITS README TODO
+}