summaryrefslogtreecommitdiff
path: root/dev-libs/sexpp/sexpp-0.8.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/sexpp/sexpp-0.8.7.ebuild')
-rw-r--r--dev-libs/sexpp/sexpp-0.8.7.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-libs/sexpp/sexpp-0.8.7.ebuild b/dev-libs/sexpp/sexpp-0.8.7.ebuild
deleted file mode 100644
index 4a8cbd6cf9ea..000000000000
--- a/dev-libs/sexpp/sexpp-0.8.7.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="S-expressions parser and generator library in C++"
-HOMEPAGE="https://github.com/rnpgp/sexpp"
-SRC_URI="https://github.com/rnpgp/sexpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
-IUSE="cli test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="virtual/pkgconfig
- test? ( dev-cpp/gtest )"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=on
-
- -DDOWNLOAD_GTEST=off
-
- -DWITH_COVERAGE=off
- -DWITH_SANITIZERS=off
- -DWITH_SEXP_CLI=$(usex cli on off)
- -DWITH_SEXP_TESTS=$(usex test on off)
- )
-
- cmake_src_configure
-}