summaryrefslogtreecommitdiff
path: root/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild b/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild
new file mode 100644
index 000000000000..cdd27fbbbefd
--- /dev/null
+++ b/dev-libs/rocr-runtime/rocr-runtime-6.0.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic llvm
+
+LLVM_MAX_SLOT=17
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCR-Runtime-rocm-${PV}/src"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.3.0_no-aqlprofiler.patch"
+ "${FILESDIR}/${PN}-5.7.1-musl.patch"
+)
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="debug"
+
+COMMON_DEPEND="dev-libs/elfutils
+ x11-libs/libdrm"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}
+ >=dev-libs/rocm-device-libs-${PV}
+ sys-devel/clang:${LLVM_MAX_SLOT}=
+ sys-devel/lld:${LLVM_MAX_SLOT}="
+RDEPEND="${DEPEND}"
+BDEPEND="app-editors/vim-core"
+ # vim-core is needed for "xxd"
+
+src_prepare() {
+ # ... otherwise system llvm/clang is used ...
+ sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS /usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die
+
+ # Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
+ sed -e "s:-O2:--rocm-path=${EPREFIX}/usr/lib/ -O2:" -i image/blit_src/CMakeLists.txt || die
+
+ # internal version depends on git being present and random weird magic, otherwise fallback to incoherent default value
+ # fix default value to be more better
+
+ sed -i -e "s:1.7.0:${PV}:" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ use debug || append-cxxflags "-DNDEBUG"
+ local mycmakeargs=( -DINCLUDE_PATH_COMPATIBILITY=OFF )
+ cmake_src_configure
+}