summaryrefslogtreecommitdiff
path: root/dev-libs/rlog/rlog-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/rlog/rlog-1.4.ebuild')
-rw-r--r--dev-libs/rlog/rlog-1.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/rlog/rlog-1.4.ebuild b/dev-libs/rlog/rlog-1.4.ebuild
index 1f58e0626556..37b964e296d2 100644
--- a/dev-libs/rlog/rlog-1.4.ebuild
+++ b/dev-libs/rlog/rlog-1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,9 @@ SRC_URI="https://rlog.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc sparc x86"
-IUSE=""
+IUSE="valgrind"
+
+DEPEND="valgrind? ( dev-util/valgrind )"
PATCHES=(
"${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
@@ -25,6 +27,10 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ econf $(use_enable valgrind)
+}
+
src_install() {
default