summaryrefslogtreecommitdiff
path: root/dev-libs/popt/popt-1.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/popt/popt-1.18.ebuild')
-rw-r--r--dev-libs/popt/popt-1.18.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-libs/popt/popt-1.18.ebuild b/dev-libs/popt/popt-1.18.ebuild
deleted file mode 100644
index 872cc3e66b91..000000000000
--- a/dev-libs/popt/popt-1.18.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal libtool toolchain-funcs
-
-DESCRIPTION="Parse Options - Command line parser"
-HOMEPAGE="https://github.com/rpm-software-management/popt"
-SRC_URI="http://ftp.rpm.org/${PN}/releases/${PN}-1.x/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="nls static-libs"
-
-RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}"
-BDEPEND="nls? ( sys-devel/gettext )"
-
-src_prepare() {
- default
- sed -i -e 's:lt-test1:test1:' tests/testit.sh || die
- elibtoolize
-}
-
-multilib_src_configure() {
- # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
- # https://github.com/gentoo/gentoo/pull/28355
- # mold needs this too but right now tc-ld-is-mold is also not available
- if tc-ld-is-lld; then
- append-ldflags -Wl,--undefined-version
- fi
-
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable nls)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- dodoc CHANGES README
- find "${ED}" -type f -name "*.la" -delete || die
-}