summaryrefslogtreecommitdiff
path: root/dev-libs/pegtl/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/pegtl/files')
-rw-r--r--dev-libs/pegtl/files/pegtl-3.2.1-werror.patch (renamed from dev-libs/pegtl/files/pegtl-3.2.0-no-werror.patch)29
1 files changed, 3 insertions, 26 deletions
diff --git a/dev-libs/pegtl/files/pegtl-3.2.0-no-werror.patch b/dev-libs/pegtl/files/pegtl-3.2.1-werror.patch
index 32bc4b5103ef..776936bd3991 100644
--- a/dev-libs/pegtl/files/pegtl-3.2.0-no-werror.patch
+++ b/dev-libs/pegtl/files/pegtl-3.2.1-werror.patch
@@ -1,19 +1,3 @@
-https://bugs.gentoo.org/787854
-
-From b807854fc6573d59350551578375075fc61a21e1 Mon Sep 17 00:00:00 2001
-From: Sam James <sam@gentoo.org>
-Date: Tue, 15 Jun 2021 01:31:40 +0000
-Subject: [PATCH] Drop -Werror
-
-Signed-off-by: Sam James <sam@gentoo.org>
----
- Makefile | 2 +-
- src/example/pegtl/CMakeLists.txt | 2 +-
- src/test/pegtl/CMakeLists.txt | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 3ecca07..2b8fa20 100644
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ endif
@@ -25,8 +9,6 @@ index 3ecca07..2b8fa20 100644
HEADERS := $(shell find include -name '*.hpp')
SOURCES := $(shell find src -name '*.cpp')
-diff --git a/src/example/pegtl/CMakeLists.txt b/src/example/pegtl/CMakeLists.txt
-index d416731..4d1a417 100644
--- a/src/example/pegtl/CMakeLists.txt
+++ b/src/example/pegtl/CMakeLists.txt
@@ -60,7 +60,7 @@ foreach(examplesourcefile ${example_sources})
@@ -34,23 +16,18 @@ index d416731..4d1a417 100644
target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
else()
- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
-+ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow)
++ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow )
endif()
endforeach()
-diff --git a/src/test/pegtl/CMakeLists.txt b/src/test/pegtl/CMakeLists.txt
-index 577e310..84a8ab8 100644
--- a/src/test/pegtl/CMakeLists.txt
+++ b/src/test/pegtl/CMakeLists.txt
-@@ -146,7 +146,7 @@ foreach(testsourcefile ${test_sources})
+@@ -150,7 +150,7 @@ foreach(testsourcefile ${test_sources})
if(MSVC)
target_compile_options(${exename} PRIVATE /W4 /WX /utf-8)
else()
- target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow -Werror)
-+ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow)
++ target_compile_options(${exename} PRIVATE -pedantic -Wall -Wextra -Wshadow )
endif()
if(ANDROID)
add_test(NAME ${exename} WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} "-DANDROID_NDK=${ANDROID_NDK}" "-DTEST_RESOURCES_DIR=${CMAKE_SOURCE_DIR}" "-DTEST_RESOURCES=src/test/pegtl/data;src/test/pegtl/file_data.txt;Makefile" "-DUNITTEST=${exename}" -P ${CMAKE_CURRENT_SOURCE_DIR}/ExecuteOnAndroid.cmake)
---
-2.32.0
-