summaryrefslogtreecommitdiff
path: root/dev-libs/openssl/openssl-1.1.1q.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/openssl/openssl-1.1.1q.ebuild')
-rw-r--r--dev-libs/openssl/openssl-1.1.1q.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-libs/openssl/openssl-1.1.1q.ebuild b/dev-libs/openssl/openssl-1.1.1q.ebuild
index 50ffbb8a79f0..9182cb8af7f9 100644
--- a/dev-libs/openssl/openssl-1.1.1q.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1q.ebuild
@@ -123,6 +123,7 @@ src_prepare() {
# it's still relevant:
# - https://github.com/llvm/llvm-project/issues/55255
# - https://github.com/openssl/openssl/issues/18225
+ # - https://github.com/openssl/openssl/issues/18663#issuecomment-1181478057
# Don't remove the no strict aliasing bits below!
filter-flags -fstrict-aliasing
append-flags -fno-strict-aliasing
@@ -180,13 +181,15 @@ multilib_src_configure() {
# See if our toolchain supports __uint128_t. If so, it's 64bit
# friendly and can use the nicely optimized code paths, bug #460790.
- local ec_nistp_64_gcc_128
-
+ #local ec_nistp_64_gcc_128
+ #
# Disable it for now though (bug #469976)
- # echo "__uint128_t i;" > "${T}"/128.c
- # if ${CC} ${CFLAGS} -c "${T}"/128.c -o /dev/null >&/dev/null ; then
- # ec_nistp_64_gcc_128="enable-ec_nistp_64_gcc_128"
- # fi
+ # Do NOT re-enable without substantial discussion first!
+ #
+ #echo "__uint128_t i;" > "${T}"/128.c
+ #if ${CC} ${CFLAGS} -c "${T}"/128.c -o /dev/null >&/dev/null ; then
+ # ec_nistp_64_gcc_128="enable-ec_nistp_64_gcc_128"
+ #fi
local sslout=$(./gentoo.config)
einfo "Use configuration ${sslout:-(openssl knows best)}"