summaryrefslogtreecommitdiff
path: root/dev-libs/openct/openct-0.6.20-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/openct/openct-0.6.20-r4.ebuild')
-rw-r--r--dev-libs/openct/openct-0.6.20-r4.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-libs/openct/openct-0.6.20-r4.ebuild b/dev-libs/openct/openct-0.6.20-r4.ebuild
index 7c44328e3709..f73005a37633 100644
--- a/dev-libs/openct/openct-0.6.20-r4.ebuild
+++ b/dev-libs/openct/openct-0.6.20-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic udev user
+inherit autotools flag-o-matic udev user
DESCRIPTION="library for accessing smart card terminals"
HOMEPAGE="https://github.com/OpenSC/openct/wiki"
@@ -21,11 +21,21 @@ RDEPEND="pcsc-lite? ( >=sys-apps/pcsc-lite-1.7.2-r1:= )
DEPEND="${RDEPEND}"
BDEPEND="doc? ( app-doc/doxygen )"
+PATCHES=(
+ "${FILESDIR}"/${P}-automake.patch
+ "${FILESDIR}"/${P}-slibtool.patch
+)
+
pkg_setup() {
enewgroup openct
enewuser openctd
}
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
use debug && append-cppflags -DDEBUG_IFDH