summaryrefslogtreecommitdiff
path: root/dev-libs/opencl-clang/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/opencl-clang/files')
-rw-r--r--dev-libs/opencl-clang/files/opencl-clang-13.0.0_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-libs/opencl-clang/files/opencl-clang-13.0.0_version.patch b/dev-libs/opencl-clang/files/opencl-clang-13.0.0_version.patch
new file mode 100644
index 000000000000..1664960b6608
--- /dev/null
+++ b/dev-libs/opencl-clang/files/opencl-clang-13.0.0_version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,7 +20,7 @@
+ add_definitions(-DUSE_PREBUILT_LLVM)
+
+ if(NOT PREFERRED_LLVM_VERSION)
+- set(PREFERRED_LLVM_VERSION "12.0.0")
++ set(PREFERRED_LLVM_VERSION "13.0.0")
+ endif(NOT PREFERRED_LLVM_VERSION)
+ message(STATUS "Looking for LLVM version ${PREFERRED_LLVM_VERSION}")
+ find_package(LLVM ${PREFERRED_LLVM_VERSION} REQUIRED)