summaryrefslogtreecommitdiff
path: root/dev-libs/nsync/nsync-1.20.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/nsync/nsync-1.20.1.ebuild')
-rw-r--r--dev-libs/nsync/nsync-1.20.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/nsync/nsync-1.20.1.ebuild b/dev-libs/nsync/nsync-1.20.1.ebuild
new file mode 100644
index 000000000000..14e0c84223c0
--- /dev/null
+++ b/dev-libs/nsync/nsync-1.20.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A C library that exports various synchronization primitives, such as mutexes"
+HOMEPAGE="https://github.com/google/nsync"
+SRC_URI="https://github.com/google/nsync/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DOCS=( README )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DNSYNC_ENABLE_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}