summaryrefslogtreecommitdiff
path: root/dev-libs/nmeap/nmeap-0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/nmeap/nmeap-0.3.ebuild')
-rw-r--r--dev-libs/nmeap/nmeap-0.3.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/nmeap/nmeap-0.3.ebuild b/dev-libs/nmeap/nmeap-0.3.ebuild
deleted file mode 100644
index 0a0e61c6988e..000000000000
--- a/dev-libs/nmeap/nmeap-0.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Extensible NMEA-0183 (GPS) data parser in standard C"
-HOMEPAGE="http://nmeap.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc"
-
-DEPEND="doc? ( app-doc/doxygen )"
-
-src_prepare() {
- default
-
- # Repsect users CFLAGS for the static lib archive
- sed -i -e 's/CFLAGS =/CFLAGS +=/' -e 's/-g -O0 -Werror//' src/Makefile || die
-
- # Don't build test programs, they are not needed
- sed -i -e '/TST/d' Makefile || die
-
- # Silent output of Doxygen and update it, since it is quite old
- if use doc; then
- sed -i -e 's/QUIET.*/QUIET = YES/' Doxyfile || die
- doxygen -u Doxyfile 2>/dev/null || die
- fi
-}
-
-src_compile() {
- local myemakeopts=(
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- )
-
- emake "${myemakeopts[@]}"
-
- if use doc; then
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- dolib.a lib/libnmeap.a
-
- doheader inc/nmeap.h inc/nmeap_def.h
-
- if use doc; then
- local HTML_DOCS=( "doc/tutorial.html" "doc/html" )
- fi
-
- einstalldocs
-}