summaryrefslogtreecommitdiff
path: root/dev-libs/mmtf-cpp/mmtf-cpp-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mmtf-cpp/mmtf-cpp-1.1.0.ebuild')
-rw-r--r--dev-libs/mmtf-cpp/mmtf-cpp-1.1.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-libs/mmtf-cpp/mmtf-cpp-1.1.0.ebuild b/dev-libs/mmtf-cpp/mmtf-cpp-1.1.0.ebuild
new file mode 100644
index 000000000000..c31d0595eb2f
--- /dev/null
+++ b/dev-libs/mmtf-cpp/mmtf-cpp-1.1.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="The pure C++ implementation of the MMTF API, decoder and encoder"
+HOMEPAGE="https://github.com/rcsb/mmtf-cpp"
+SRC_URI="https://github.com/rcsb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-libs/msgpack"
+RDEPEND="${DEPEND}"
+BDEPEND=""