summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc/mimalloc-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-2.1.1.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.1.1.ebuild b/dev-libs/mimalloc/mimalloc-2.1.1.ebuild
new file mode 100644
index 000000000000..5c8b6056d6ae
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="hardened test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMI_SECURE=$(usex hardened)
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}