summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc/mimalloc-2.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-2.0.6.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.0.6.ebuild b/dev-libs/mimalloc/mimalloc-2.0.6.ebuild
new file mode 100644
index 000000000000..2edb208e732f
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: build hardened variant?
+ #-DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+
+ -DMI_BUILD_OBJECT=OFF
+ -DMI_BUILD_STATIC=OFF
+ )
+
+ cmake-multilib_src_configure
+}