summaryrefslogtreecommitdiff
path: root/dev-libs/marisa
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/marisa')
-rw-r--r--dev-libs/marisa/Manifest4
-rw-r--r--dev-libs/marisa/files/marisa-0.2.4-python.patch15
-rw-r--r--dev-libs/marisa/marisa-0.2.4.ebuild86
-rw-r--r--dev-libs/marisa/metadata.xml11
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-libs/marisa/Manifest b/dev-libs/marisa/Manifest
new file mode 100644
index 000000000000..1093a76afbf0
--- /dev/null
+++ b/dev-libs/marisa/Manifest
@@ -0,0 +1,4 @@
+AUX marisa-0.2.4-python.patch 683 BLAKE2B 5d26607877b3f4614a558d085de11360783d2a448749e7a7fed2ac805e4b6dc5d4b89c29c37fe70a34cc4745789b9ff93b4f398860d8014303a4290bbd1196c5 SHA512 fa718a385cfef196833f5a9aa23c31839505a0101df3d25a73616942845668891f818213b89a36689ec93e678289128add1f6450e15fb995233621faaa76d700
+DIST marisa-0.2.4.tar.gz 502552 BLAKE2B aa8e6ce11c35db41f386d1c5d3ffdf56a940f298e10a7f6b1fa14cb80c27c9c4af1d4d61c58786f96e9598effe26379127c69b8fe72b1ca561a44ee2b9cddc61 SHA512 71aee3ae034d1ce725d986bef43472d61bd64f0af3ccda01bb019cce03f0872629b6a1b305e717056bef06e036372323b2a67e5dc69705d6a74e028b5e2553e4
+EBUILD marisa-0.2.4.ebuild 2308 BLAKE2B 1ded7f2a44a33c54e4c8994409d553d594678d617f8367bebbdcfd5fc8193f7e1467cff6360accfd1147318122528df78c596f0deb0da5b48bb8dc2aeb534d24 SHA512 e0dabeef8c8c8d890fbf46f2a990a6edfc2bbe3624015747ce6113e10bd540209c778d15ecb7f8dc5314acca9912ab13bbfe5b97ac9aa6ec4c6282a2a71f0b75
+MISC metadata.xml 317 BLAKE2B 16fd28ba01ffdf67af29ea7f6b41be190ecff6ab88706b0cb04b6e9dee5a623087652e666af02cff1c3ed3bd4b42f252adf5fce1b08c2eb9a998e8c112dba922 SHA512 0e782fba322f87cfc0f180f812d0e33630c4295df1f434d497aba1a7f9d922e9674a3c23a821211cbe11d419eee70c25dbabb7508abc7bd56267e9648a1e721c
diff --git a/dev-libs/marisa/files/marisa-0.2.4-python.patch b/dev-libs/marisa/files/marisa-0.2.4-python.patch
new file mode 100644
index 000000000000..fba0e016d475
--- /dev/null
+++ b/dev-libs/marisa/files/marisa-0.2.4-python.patch
@@ -0,0 +1,15 @@
+--- bindings/python/setup.py 2011-05-14 07:20:52.000000000 +0200
++++ bindings/python/setup.py 2013-08-02 17:04:16.423771834 +0200
+@@ -1,8 +1,10 @@
+ from distutils.core import setup, Extension
+
+ marisa_module = Extension("_marisa",
+- sources=["marisa-swig_wrap.cxx", "marisa-swig.cxx"],
+- libraries=["marisa"])
++ sources=["marisa-swig.i", "marisa-swig.cxx"],
++ swig_opts=["-c++"],
++ libraries=["marisa"], library_dirs=["../../lib/.libs"],
++ include_dirs=["../../lib"])
+
+ setup(name = "marisa",
+ ext_modules = [marisa_module],
diff --git a/dev-libs/marisa/marisa-0.2.4.ebuild b/dev-libs/marisa/marisa-0.2.4.ebuild
new file mode 100644
index 000000000000..8f2ea0a1c7e2
--- /dev/null
+++ b/dev-libs/marisa/marisa-0.2.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Matching Algorithm with Recursively Implemented StorAge"
+HOMEPAGE="https://github.com/s-yata/marisa-trie https://code.google.com/archive/p/marisa-trie/"
+SRC_URI="https://marisa-trie.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc ppc64 x86"
+IUSE="python doc static-libs cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_sse4a cpu_flags_x86_popcnt"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )"
+
+# implied by --enable switches
+REQUIRED_USE="
+ cpu_flags_x86_popcnt? ( cpu_flags_x86_sse3 )
+ cpu_flags_x86_sse4a? ( cpu_flags_x86_popcnt cpu_flags_x86_sse3 )
+ cpu_flags_x86_sse4_2? ( cpu_flags_x86_popcnt cpu_flags_x86_sse4_1 )
+ cpu_flags_x86_sse4_1? ( cpu_flags_x86_ssse3 )
+ cpu_flags_x86_ssse3? ( cpu_flags_x86_sse3 )
+ cpu_flags_x86_sse3? ( cpu_flags_x86_sse2 )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python.patch"
+ if use python; then
+ pushd bindings/python || die
+ ln -sf ../marisa-swig.i marisa-swig.i || die
+ ln -sf ../marisa-swig.h marisa-swig.h || die
+ ln -sf ../marisa-swig.cxx marisa-swig.cxx || die
+ distutils-r1_src_prepare
+ popd || die
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable cpu_flags_x86_sse3 sse3)
+ $(use_enable cpu_flags_x86_ssse3 ssse3)
+ $(use_enable cpu_flags_x86_sse4_1 sse4.1)
+ $(use_enable cpu_flags_x86_sse4_2 sse4.2)
+ # sse4 is just an alias to sse4.2
+ $(use_enable cpu_flags_x86_sse4a sse4a)
+ $(use_enable cpu_flags_x86_popcnt popcnt)
+ )
+ econf "${myeconfargs[@]}"
+
+ if use python; then
+ pushd bindings/python || die
+ distutils-r1_src_configure
+ popd || die
+ fi
+}
+
+src_compile() {
+ default
+ if use python; then
+ pushd bindings/python || die
+ distutils-r1_src_compile
+ popd || die
+ fi
+}
+
+src_install() {
+ default
+ if use python; then
+ pushd bindings/python || die
+ distutils-r1_src_install
+ popd || die
+ fi
+ use doc && dohtml docs/readme.en.html
+ prune_libtool_files
+}
diff --git a/dev-libs/marisa/metadata.xml b/dev-libs/marisa/metadata.xml
new file mode 100644
index 000000000000..4aa8461d2b54
--- /dev/null
+++ b/dev-libs/marisa/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">s-yata/marisa-trie</remote-id>
+ </upstream>
+</pkgmetadata>