summaryrefslogtreecommitdiff
path: root/dev-libs/marisa
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/marisa')
-rw-r--r--dev-libs/marisa/Manifest4
-rw-r--r--dev-libs/marisa/marisa-0.2.6.ebuild10
-rw-r--r--dev-libs/marisa/marisa-9999.ebuild11
3 files changed, 12 insertions, 13 deletions
diff --git a/dev-libs/marisa/Manifest b/dev-libs/marisa/Manifest
index 32559c2b511f..d0d185471bcf 100644
--- a/dev-libs/marisa/Manifest
+++ b/dev-libs/marisa/Manifest
@@ -2,6 +2,6 @@ AUX marisa-0.2.6-loong_word_size.patch 565 BLAKE2B db3c245c896d265545a1b99202c60
AUX marisa-0.2.6-riscv_word_size.patch 486 BLAKE2B fef98bb16375bb482bfc5a219ecb61f9401e2bd560962f99e82c1725207c95a52c3ee9699d1fdc95bdfd972e15d6ca63e6c2e5c67938a385c592423205be8c08 SHA512 7da1120c5db4d8c902fd0bd16aa86f95cff09e8d81aa8d4140353eefbd2e3d7a100a9f38909193a5fd2333a652ce8b65198b0664792fe390790dd87883f6a7fa
AUX marisa-0.2.6-sparc64_word_size.patch 783 BLAKE2B 339bbaecd8686e1af2f6bbcb9709020f2af0d13f9bef4fc49ffd2deb3096ab2ea556c0a32a8ae5b74555bf171c553a43c6bebb4ec05e9696d857c512525550d4 SHA512 d894d7a55cc9a617711a19c8be25a60eea9f808906be7f8ccca4d5cc970e9b5cb2b3e88fc111037e18f831e4c6a7b96c134eea5a2417edc89a402ef96e100689
DIST marisa-0.2.6.tar.gz 168332 BLAKE2B 3b8a89a9a0b344d9de96edb5bf17c50db07da373e75eba098f48c9064321d579ac104db622608119377084c79165bf558c804eaff591903b67330b13bc8acf55 SHA512 c094e4b22e1457efdd20f2b978ee421b53e36ed94e4fdbd8944136c0ba23da4f6ba9fe3a2c64729c1426aee4dbe8098bfa5eebb943ae7fdaa4eec760485c564d
-EBUILD marisa-0.2.6.ebuild 2993 BLAKE2B c405cef0011d0dec13d5f23a4a1a5395b23794a2612687f987af7126df126730d261b4c860e31d39697c0b5402179e294e5153b07e527a640c88ab3a35ae7b0b SHA512 aff0cd8c9fb2748531802d9ff9a31b01dc09fab491c420758da9ce991a0354ec2b740b51e23e09f0ef30d45adb96a302157ea3ec25f31cc84286cdd90c56bd84
-EBUILD marisa-9999.ebuild 2780 BLAKE2B 310377e8f56fa08895d167ec454a33065ad3da616a1bcdf1efe1b38c2ed21a204162068264f9d2c60adfd6adca93ccccc48f81a2d9bb057d7aca8d603ce8aedf SHA512 84daafc1440f4541ca3377b944f9759cf18292dd1905c684360d72ea0ba26ab739a478e52c95e275ff768a959de812de5e3add95b4422f173a268350c5dccdfa
+EBUILD marisa-0.2.6.ebuild 3031 BLAKE2B 2097b5ab4c2d2e07c8abc3481d62297326d1ddba0d0aa1f2ea7a149ad3588938d0bff3c3a71b3e0c72891e1df8a0a9e24a36ff79c2c88c5c0c14205195797cd6 SHA512 d8db82e9659f67ad7b991e68eb936c1d6bb4a64c293e4645ae4a83d95a94da4f6c1731010e923fe5f1307a3ed19b38fd5e1cdcf91fd0af84aeb026791409b158
+EBUILD marisa-9999.ebuild 2806 BLAKE2B 3e4a87895cb5356f44c0ef67937326d5f7e367af51135eb846953e4826fff65838135bce34ec14edbcd678be6168b1c0e1260d0373a3989f9091d6eec38c4691 SHA512 b60839f23a16c85b565d27d1b13103170626eb449bbc3273692e505a977c91cad9eb165e56a635a95882a4680ef7ba3b45c1c74caafa92c388b6f5a42e44f78a
MISC metadata.xml 318 BLAKE2B d42d95f7c68f1cd36d197f9e56cba84c6c3f848ee0b3fc2350007963b8cfc6325856078d371d0764f0667404148bf2da1289b38acb5797da3513cb93cbc83b99 SHA512 56330759de72280c5fef38bdb67f4547a38455beaa6697ebfba262232954f4164275a4cd8b713dce35bb9b7acb21aaab2c9b2a429f6fdc50f9770b1fd0e02630
diff --git a/dev-libs/marisa/marisa-0.2.6.ebuild b/dev-libs/marisa/marisa-0.2.6.ebuild
index 6e587ffcb945..47f2023b5fad 100644
--- a/dev-libs/marisa/marisa-0.2.6.ebuild
+++ b/dev-libs/marisa/marisa-0.2.6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 2014-2023 Gentoo Authors
+# Copyright 2014-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517="setuptools"
DISTUTILS_OPTIONAL="1"
DISTUTILS_EXT=1
@@ -16,9 +17,7 @@ fi
DESCRIPTION="Matching Algorithm with Recursively Implemented StorAge"
HOMEPAGE="https://github.com/s-yata/marisa-trie https://code.google.com/archive/p/marisa-trie/"
-if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
-else
+if [[ "${PV}" != "9999" ]]; then
SRC_URI="https://github.com/s-yata/marisa-trie/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
@@ -30,6 +29,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="python? (
${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
dev-lang/swig
)"
DEPEND="python? ( ${PYTHON_DEPS} )"
diff --git a/dev-libs/marisa/marisa-9999.ebuild b/dev-libs/marisa/marisa-9999.ebuild
index 7731d92f28e3..45c481f3fb3a 100644
--- a/dev-libs/marisa/marisa-9999.ebuild
+++ b/dev-libs/marisa/marisa-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 2014-2023 Gentoo Authors
+# Copyright 2014-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517="setuptools"
DISTUTILS_OPTIONAL="1"
DISTUTILS_EXT=1
@@ -16,20 +17,18 @@ fi
DESCRIPTION="Matching Algorithm with Recursively Implemented StorAge"
HOMEPAGE="https://github.com/s-yata/marisa-trie https://code.google.com/archive/p/marisa-trie/"
-if [[ "${PV}" == "9999" ]]; then
- SRC_URI=""
-else
+if [[ "${PV}" != "9999" ]]; then
SRC_URI="https://github.com/s-yata/marisa-trie/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="|| ( BSD-2 LGPL-2.1+ )"
SLOT="0"
-KEYWORDS=""
IUSE="python static-libs"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="python? (
${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
dev-lang/swig
)"
DEPEND="python? ( ${PYTHON_DEPS} )"