summaryrefslogtreecommitdiff
path: root/dev-libs/libx86emu/libx86emu-3.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libx86emu/libx86emu-3.5.ebuild')
-rw-r--r--dev-libs/libx86emu/libx86emu-3.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libx86emu/libx86emu-3.5.ebuild b/dev-libs/libx86emu/libx86emu-3.5.ebuild
new file mode 100644
index 000000000000..f4c40aa7a9ab
--- /dev/null
+++ b/dev-libs/libx86emu/libx86emu-3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A library for emulating x86"
+HOMEPAGE="https://github.com/wfeldt/libx86emu"
+SRC_URI="https://github.com/wfeldt/libx86emu/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ echo "${PV}" > VERSION || die
+ rm -fr git2log || die
+}
+
+src_compile() {
+ emake shared CC=$(tc-getCC) CFLAGS="${CFLAGS} -fPIC -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ emake test CC=$(tc-getCC) CFLAGS="${CFLAGS} -fPIC -Wall" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ dodoc README.md
+}