summaryrefslogtreecommitdiff
path: root/dev-libs/libx86/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libx86/files')
-rw-r--r--dev-libs/libx86/files/libx86-0.99-ifmask.patch21
-rw-r--r--dev-libs/libx86/files/libx86-1.1-makefile.patch28
-rw-r--r--dev-libs/libx86/files/libx86-1.1-x86emu.patch38
3 files changed, 0 insertions, 87 deletions
diff --git a/dev-libs/libx86/files/libx86-0.99-ifmask.patch b/dev-libs/libx86/files/libx86-0.99-ifmask.patch
deleted file mode 100644
index c99eeb819f72..000000000000
--- a/dev-libs/libx86/files/libx86-0.99-ifmask.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- lrmi.c.orig 2008-09-06 12:24:36.070136428 +0200
-+++ lrmi.c 2008-09-06 12:28:10.584287458 +0200
-@@ -55,6 +55,18 @@ OTHER DEALINGS IN THE SOFTWARE.
- #include "x86-common.h"
-
- #if defined(__linux__)
-+#ifndef TF_MASK
-+#define TF_MASK X86_EFLAGS_TF
-+#endif
-+#ifndef IF_MASK
-+#define IF_MASK X86_EFLAGS_IF
-+#endif
-+#ifndef IOPL_MASK
-+#define IOPL_MASK X86_EFLAGS_IOPL
-+#endif
-+#ifndef VIF_MASK
-+#define VIF_MASK X86_EFLAGS_VIF
-+#endif
- #define DEFAULT_VM86_FLAGS (IF_MASK | IOPL_MASK)
- #elif defined(__NetBSD__) || defined(__FreeBSD__)
- #define DEFAULT_VM86_FLAGS (PSL_I | PSL_IOPL)
diff --git a/dev-libs/libx86/files/libx86-1.1-makefile.patch b/dev-libs/libx86/files/libx86-1.1-makefile.patch
deleted file mode 100644
index 471c3fbc78fd..000000000000
--- a/dev-libs/libx86/files/libx86-1.1-makefile.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.orig 2013-02-11 16:35:56.834368910 +0400
-+++ Makefile 2013-02-11 16:36:02.587369368 +0400
-@@ -22,7 +22,7 @@
- $(AR) cru libx86.a $(OBJECTS)
-
- shared: $(OBJECTS)
-- $(CC) $(CFLAGS) -o libx86.so.1 -shared -Wl,-soname,libx86.so.1 $(OBJECTS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o libx86.so.1 -shared -Wl,-soname,libx86.so.1 $(OBJECTS)
-
- objclean:
- $(MAKE) -C x86emu clean
-@@ -31,8 +31,14 @@
- clean: objclean
- rm -f *.so.1 *.a
-
--install: libx86.so.1
-+install-shared: libx86.so.1
- install -D libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so.1
-- install -D libx86.a $(DESTDIR)$(LIBDIR)/libx86.a
- ln -sf libx86.so.1 $(DESTDIR)$(LIBDIR)/libx86.so
-+
-+install-header:
- install -p -m 0644 -D lrmi.h $(DESTDIR)/usr/include/libx86.h
-+
-+install-static:
-+ install -D libx86.a $(DESTDIR)$(LIBDIR)/libx86.a
-+
-+install: install-shared install-static install-header
diff --git a/dev-libs/libx86/files/libx86-1.1-x86emu.patch b/dev-libs/libx86/files/libx86-1.1-x86emu.patch
deleted file mode 100644
index 7b4fe428e1b3..000000000000
--- a/dev-libs/libx86/files/libx86-1.1-x86emu.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -Naur libx86-1.1+ds1.orig/Makefile libx86-1.1+ds1/Makefile
---- a/libx86-1.1/Makefile 2008-05-19 12:28:59.000000000 +0300
-+++ b/libx86-1.1/Makefile 2012-02-20 01:32:03.750068423 +0200
-@@ -5,6 +5,7 @@
- ifeq ($(BACKEND),x86emu)
- OBJECTS += thunk.o x86emu/decode.o x86emu/debug.o x86emu/fpu.o \
- x86emu/ops.o x86emu/ops2.o x86emu/prim_ops.o x86emu/sys.o
-+ CFLAGS += -DX86EMU
- else
- OBJECTS += lrmi.o
- endif
-diff -Naur libx86-1.1+ds1.orig/thunk.c libx86-1.1+ds1/thunk.c
---- a/libx86-1.1+ds1.orig/thunk.c 2008-04-03 03:48:00.000000000 +0300
-+++ b/libx86-1.1/thunk.c 2012-02-20 01:12:56.468820192 +0200
-@@ -32,6 +32,7 @@
- #define TRUE 1
- #define FALSE 0
-
-+#ifndef X86EMU
- #define __BUILDIO(bwl,bw,type) \
- static inline void out##bwl##_local(unsigned long port, unsigned type value) { __asm__ __volatile__("out" #bwl " %" #bw "0, %w1" : : "a"(value), "Nd"(port)); \
- }\
-@@ -44,6 +45,15 @@
- __BUILDIO(b,b,char)
- __BUILDIO(w,w,short)
- __BUILDIO(l,,int)
-+#else
-+/* use libc functions */
-+#define inb_local inb
-+#define inw_local inw
-+#define inl_local inl
-+#define outb_local outb
-+#define outw_local outw
-+#define outl_local outl
-+#endif /* X86EMU */
-
-
- char *mmap_addr = SHMERRORPTR;