summaryrefslogtreecommitdiff
path: root/dev-libs/libvterm/libvterm-0.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libvterm/libvterm-0.1.2.ebuild')
-rw-r--r--dev-libs/libvterm/libvterm-0.1.2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-libs/libvterm/libvterm-0.1.2.ebuild b/dev-libs/libvterm/libvterm-0.1.2.ebuild
index 6802cf9d98af..d4ac11e08b8e 100644
--- a/dev-libs/libvterm/libvterm-0.1.2.ebuild
+++ b/dev-libs/libvterm/libvterm-0.1.2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
+
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
@@ -17,11 +18,12 @@ BDEPEND="
sys-devel/libtool
virtual/pkgconfig
"
-DEPEND=""
RDEPEND="!dev-libs/libvterm-neovim"
src_compile() {
+ tc-export CC
append-cflags -fPIC
+
emake VERBOSE=1 PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)"
}
@@ -32,5 +34,6 @@ src_install() {
PREFIX="${EPREFIX}/usr" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
DESTDIR="${D}" install
- find "${D}" -name '*.la' -delete || die "Failed to prune libtool files"
+
+ find "${ED}" -name '*.la' -delete || die "Failed to prune libtool files"
}