summaryrefslogtreecommitdiff
path: root/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild')
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
index b89571d039c5..6b9420aefe1f 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit toolchain-funcs
MY_P="${P/_p/-}"
-DESCRIPTION="mapping tool for UTF-8 strings"
+
+DESCRIPTION="A clean C Library for processing UTF-8 Unicode data"
HOMEPAGE="http://www.netsurf-browser.org/"
SRC_URI="https://download.netsurf-browser.org/libs/releases/${MY_P}-src.tar.gz"
@@ -16,13 +17,12 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="dev-util/netsurf-buildsystem"
-
S="${WORKDIR}/${MY_P}"
_emake() {
source "${EPREFIX}"/usr/share/netsurf-buildsystem/gentoo-helpers.sh
netsurf_define_makeconf
- emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared "${@}"
}
src_compile() {