summaryrefslogtreecommitdiff
path: root/dev-libs/libunibreak/libunibreak-5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libunibreak/libunibreak-5.1.ebuild')
-rw-r--r--dev-libs/libunibreak/libunibreak-5.1.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/dev-libs/libunibreak/libunibreak-5.1.ebuild b/dev-libs/libunibreak/libunibreak-5.1.ebuild
index ee39d6ae81d0..c914a23956fc 100644
--- a/dev-libs/libunibreak/libunibreak-5.1.ebuild
+++ b/dev-libs/libunibreak/libunibreak-5.1.ebuild
@@ -6,23 +6,36 @@ EAPI=8
DESCRIPTION="Line and word breaking library"
HOMEPAGE="http://vimgadgets.sourceforge.net/libunibreak/"
SRC_URI="https://github.com/adah1972/${PN}/releases/download/${PN}_$(ver_rs 1- '_')/${P}.tar.gz"
+SRC_URI+="
+ test? (
+ http://www.unicode.org/Public/UNIDATA/auxiliary/LineBreakTest.txt -> ${PN}-LineBreakTest.txt
+ http://www.unicode.org/Public/UNIDATA/auxiliary/WordBreakTest.txt -> ${PN}-WordBreakTest.txt
+ http://www.unicode.org/Public/UNIDATA/auxiliary/GraphemeBreakTest.txt -> ${PN}-GraphemeBreakTest.txt
+ )
+"
LICENSE="ZLIB"
SLOT="0/5"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="doc +man static-libs"
-
-# Tests require internet access to www.unicode.org
-RESTRICT="test"
+IUSE="doc +man static-libs test"
+RESTRICT="!test? ( test )"
BDEPEND="man? ( app-doc/doxygen )"
src_prepare() {
+ default
+
if use man; then
echo 'GENERATE_MAN=YES' >> Doxyfile || die
echo 'GENERATE_HTML=NO' >> Doxyfile || die
fi
- default
+
+ if use test; then
+ local file
+ for file in LineBreakTest.txt WordBreakTest.txt GraphemeBreakTest.txt ; do
+ ln -s "${DISTDIR}"/${PN}-${file} "${S}"/src/${file} || die
+ done
+ fi
}
src_configure() {