summaryrefslogtreecommitdiff
path: root/dev-libs/libstrl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libstrl')
-rw-r--r--dev-libs/libstrl/Manifest2
-rw-r--r--dev-libs/libstrl/libstrl-0.5.1-r2.ebuild (renamed from dev-libs/libstrl/libstrl-0.5.1-r1.ebuild)26
2 files changed, 15 insertions, 13 deletions
diff --git a/dev-libs/libstrl/Manifest b/dev-libs/libstrl/Manifest
index 60d594c8bdff..2b36a9eb46e3 100644
--- a/dev-libs/libstrl/Manifest
+++ b/dev-libs/libstrl/Manifest
@@ -1,3 +1,3 @@
DIST libstrl-0.5.1.tar.bz2 259026 BLAKE2B 9f2b576b1a86361f982069a1e7b1c12e0f47918637ed43add261379c195ba9ddeb5b8ca04b0811b75373235c79ff5b254a42c2e3ed360da410039a913137dd60 SHA512 c79b37aef2cf909529e3afabdf472730f9df2eb3605eeb41a74b56f1c9c43a5be1f23c7f383c4b1c2aacb81b9df1d455a3fe9ec1083d5fcabae4c82ef916df92
-EBUILD libstrl-0.5.1-r1.ebuild 736 BLAKE2B 1f87b29a0e88d58fd8a8ed52af3b036c9bd9016cbeb852bb1372ef0915ab71ae856e3178ee7c5c49bb434c4f51ec9437c1ec3c7347eb6ce4e22dfb26667c1b3e SHA512 8a3635c85bde10411e6ddbf1809f16920c84915faa7760fb1255666020c3fa655f4768a230df6d204d07966383cf85a8068f4d63f3a23f0bed8ba25405fa1154
+EBUILD libstrl-0.5.1-r2.ebuild 684 BLAKE2B 932bf55ce17ad9a64b813299698d7487ea0264567d46692c8d73101b2644ec6af464516cd1831c1cb3a5f49823ebb031e93e5da093ae7f34adaa4306a7ef1e8d SHA512 86e7c0bc18d7752a94b140a8ed8a8d0c51d7cb83807f946f19ee233b09537296231643eb7e36763dbf4c2ded35a62ea3c9cf63e8fbeda8277be0975177ef8655
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/dev-libs/libstrl/libstrl-0.5.1-r1.ebuild b/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild
index 33b911319375..13faa3a50256 100644
--- a/dev-libs/libstrl/libstrl-0.5.1-r1.ebuild
+++ b/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit toolchain-funcs multilib-minimal
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), strnlen(), getline()"
HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
@@ -11,23 +12,24 @@ SRC_URI="http://mirror.ohnopub.net/mirror/${P}.tar.bz2"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x64-macos"
-IUSE="doc static-libs test"
+IUSE="doc test"
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
doc? ( app-doc/doxygen )
test? ( dev-libs/check )
"
-src_prepare() {
- default
- multilib_copy_sources
-}
-
-multilib_src_configure() {
+src_configure() {
tc-export AR
+
econf \
- $(use_enable static-libs static) \
$(use_with doc doxygen) \
$(use_with test check)
}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}