summaryrefslogtreecommitdiff
path: root/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild')
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..7e8df7fae210
--- /dev/null
+++ b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic versionator
+
+DESCRIPTION="Simple C-library to access Oracle databases via the OCI interface"
+SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
+HOMEPAGE="http://www.poitschke.de/libsqlora8/index_noframe.html"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="orathreads static-libs +threads"
+
+RDEPEND="dev-db/oracle-instantclient"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="?? ( orathreads threads )"
+
+src_configure() {
+ local myconf
+
+ local ORACLE_VER="$(best_version dev-db/oracle-instantclient)"
+ ORACLE_VER="${ORACLE_VER#*/*-*-}" #reduce it to ${PV}-${PR}
+ ORACLE_VER="$(get_version_component_range 1-2 ${ORACLE_VER})"
+ append-ldflags -L"/usr/lib/oracle/${ORACLE_VER}/client/lib"
+
+ use threads && myconf="--with-threads=posix"
+ use orathreads && myconf="--with-threads=oracle"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ # Parallel compilation is not supported
+ emake -j1
+}
+
+src_install () {
+ default
+ prune_libtool_files
+ dodoc ChangeLog NEWS NEWS-2.2
+
+ # TODO
+ # Copy contents of doc and examples directory to proper place
+ rm -r "${D}/usr/share/doc/packages"
+}